Debugging a… Bosch compound mitre saw

A year or so ago I picked up a secondhand Bosch PCM-8S compound mitre saw for my workshop. Handy little saw, handles most things I need to do. One thing I accepted at the time was the built in Led lights and laser didn’t work. Didn’t think much of it given that most of it was chock full of sawdust.

Today though, curiosity got the better of me and I decided to find out if it was fixable. I’m not going to list in detail everything I did, but needless to say I started in the wrong place and ultimately found the issue in the last place I looked (and last place I expected):

1) took the light and laser fixture apart. Should never have been this and after hooking it up to a 9v battery separately, determined it wasn’t.
2) Took the battery compartment apart. Cleaned out the sawdust. Still didn’t work. Put in batteries that did actually work and ruled out the battery compartment.
3) checked continuity in all the cabling. All fine.
4) which left me with the switchgear. After bypassing this, determined this was the fault. Swapped in a simple replacement and yep, all confirmed.

This was surprising. It’s a simple rocker switch which will only rarely fail. Unfortunately it’s a sealed unit so now to try and find a replacement. From what I can tell it’s a JEC JS-606P but this seems to be a generic part no.

Anyway, if you bizarrely have a similar issue… test your switch.

1 Trackback / Pingback

  1. Debugging a Bosch compound mitre saw... part 2! - matt's debates

Leave a Reply

Your email address will not be published.


*