Debugging a Bosch compound mitre saw… part 2!

I previously wrote about trying to figure out why the Led/Laser switch on my Bosch PCM-8S didn’t work. I determined the switch was faulty.

After a bit of a hunt, I found the part here: http://www.powertoolspares.com/tool/bosch/spares-and-accessories-for-slide-mitre-saw-pcm-8-s/3603l02070/spares/ – looks like a good resource. £6 for the switch seemed reasonable – but £10 for postage, didn’t. It’s not uncommon to encounter this sort of thing living in the Channel Islands, it nevertheless it’s irritating.

So before coughing up the £16 for the new part, I figured I’d see if there was anything to be done to rescue the existing switch. I previously thought it was a sealed unit, but after a bit of prying with a mini flathead screwdriver – turns out it’s not. And, much like everything else on this saw, it was all gunked up with crap. And after cleaning it up, and reassembling, hey presto, the switch is working again. Result.

A few notes…

Inside each switch is a mini spring and a tiny ball bearing. They will spring out when you prize the button out… so do it carefully and be prepared to scrabble around on the floor looking for them.

I just cleaned it out by scraping out the crap and spraying with a bit of contact cleaner.

Reassembling is a fiddly bastard of a job. It’s a case of balancing the moving contact in the right place and then trying to get the ball bearing central on the contact so you can then push the button back on top. It will infuriate you and you will swear a lot. But with a bit of patience, you should get there.

I’m not sure this fix will last forever, but it is at least working now, which is the main thing. Whether I actually use my new found functionality, remains to be seen.

Be the first to comment

Leave a Reply

Your email address will not be published.


*